Aktuelle FontAwesome-Symbole im WBB 4.0.x.x nutzen

Liebe Kunden von Powerstylez.com!
Seit dem 18.10.2021 stehen für unsere kommerziellen Kunden und Nutzer kostenloser Stilangebote die aktuellen Updates ALLER Stile inklusive Version für das WSC 5.4.x im Shop bereit. Das angebotene Update bei Nutzung des WSC 5.4 wird dringend empfohlen da es mit einigen Stilen zu schwerwiegenden Problemen beim Anmelden kommen kann.

Noch ein kleiner Hinweis... Für unsere Kunden (Neukunden & Bestandskunden) die REVO Reloaded Shoutbox für das WSC 5.x.x kostenlos im Shop zum herunterladen - warum eine Shoutbox wo anders kaufen?!

Ihr Gino Zantarelli

  • Wer ein älteres WBB 4.0.x.x. nutzt kennt das Problem, Woltlab aktualisiert die FontAwesome-Version einfach nicht und lässt die Besitzer mit veralteten Symbolen alleine.


    Um auch die aktuellsten Symbole für einen Stil nutzen zu können fügt man folgende Codezeile der CSS-Definition des jeweiligen Stils oberhalb hinzu (hier Version 4.6.1):

    Code
    @import url(https://maxcdn.bootstrapcdn.com/font-awesome/4.6.1/css/font-awesome.min.css);

    Falls eine neuere Version von FontAwesome veröffentlicht wird kann einfach im Code die Versionsnummer bearbeitet werden. Selbstverständlich kann diese Codezeile auch für das aktuelle WBB 4 1.x.x genutzt werden.

  • Hi,

    es gibt die nicht unterstützte Version 5 von FontAwesome, Kittmedia hat ein Plugin dafür veröffentlicht das leider nicht alle Symbole der Version 4.7 ausgewechselt werden. WSC 5.2.x.x nutzt ausschließlich NUR Version 4.7 und lehnt aus technischen Gründen die neuen FA-Symbole ab.


    Gino ;-)

  • Hi,

    es gibt die nicht unterstützte Version 5 von FontAwesome, Kittmedia hat ein Plugin dafür veröffentlicht das leider nicht alle Symbole der Version 4.7 ausgewechselt werden. WSC 5.2.x.x nutzt ausschließlich NUR Version 4.7 und lehnt aus technischen Gründen die neuen FA-Symbole ab.


    Gino ;-)

    Ok danke für die Info.

    Dann kann ich also nur auf die Standard-Icons zurückgreifen die mit an "Bord" sind?

  • Ok nochmals danke,


    Leider werden bei mir teilsweise aber nur die normalen Icons angezeigt.


    Ich habe keine "Spezial-Icons" ausgewählt.Wenn ich ins html schau,steht dort : Font-family : Font Awesome 5 Free


    Wie du erkennen kannst,werden teilweise meine "ausgewählten Icons" angezeigt,teilweise nicht.

    Im Adminbereich kann ich aber zugeteilten Icons sehen



    P.S.Sorry ,ich habe keinen anderen passenden Thread gefunden,ich weis wohl,das dies hier nicht der richtige Ist

  • Hi,

    du kannst aus technischen Gründen KEINE Font Awesome 5.x.x nutzen, die FA 4.x-Codes sind nicht überall konform zu FA 5.xx und daher werden auch nur bedingt Icons verändert. Nicht umsonst hat Woltlab offiziell das einbinden von FA 5 abgelehnt, es müssten zig Templates umprogrammiert werden.


    Gino ;-)

  • Hallo,

    das kann nur durch ein Plugin eingebunden sein, durch eingefügten html-import in einem veränderten Template oder als CSS Import in der CSS-Definition des Stils oder übergreifendes CSS. Da ich in diesen Stil nicht eingebunden habe oder technisch verändert sollte der Fehler von Dir verursacht sein.


    Gino ;-)